Ergebnis 1 bis 2 von 2
  1. #1
    Registriert seit
    21.01.2011
    Beiträge
    1

    Frage [OOo CALC] Eine etwas komplizierte Formel

    Hallo Zusammen

    Ich habe folgendes Problem:
    Ich möchte gerne einen gewichteten Durchschnitt in OpenOffice Calc berechnen.
    Soweit funktioniert das auch mit folgender Formel:
    "=((15.8333*E3)+(15.8333*I3)+(15.8333*K3)+(15.8333 *M3)+(15.8333*N3)+(15.8333*O3)+(5*G3))/100"

    Nun aber das eigentliche Problem:
    Meine Datensätze sind zum Teil unvollständig, d.h. es gibt leere Stellen in der Tabelle. Ich möchte aber, dass der Durchschnitt auch dann ausgerechnet wird, wenn es Leerstellen gibt. Die Formel müsste ja dann bei jeder Zeile angepasst werden darauf welche Zellen leer sind. Kann man das automatisieren, so dass die Formel von selbst angepasst wird?

    Danke im voraus für alle Antworten!

  2. #2
    Registriert seit
    28.02.2010
    Ort
    Grossraum Aarau
    Beiträge
    573

    Gewichtetes Mittel

    Hallo nic17590

    Verwende die Funktion SUMMENPRODUKT und die Funktion SUMME.
    Angenommen die Merkmale stehen in den Zellen A2:A9 und die Ereignisse in den Zellen B2:B9 dann lautet die Formel

    Formel =SUMMENPRODUKT(A2:A9;B2:B9)/SUMME(A2:A9)

    A2:A9 ist Matrix 1 z.B. mit Merkmalen; B2:B9 ist Matrix 2 z.B. gezählte Ereignisse.

    Viele Grüsse
    grippen
    Geändert von Turakos (19.06.2012 um 06:59 Uhr)

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Firmenlink