Ergebnis 1 bis 5 von 5
  1. #1
    Registriert seit
    19.08.2007
    Beiträge
    72

    WVERWEIS dynamisch

    Guten Tag zusammen

    Ich habe ein File, in welchem ich den WVERWEIS verwende.

    Dieser hat aber den Nachteil, dass er im Bereich Zeilenindex statisch ist. Wenn nun der der Bezug ändert, muss ich dies immer händisch machen. Ich suche nun eine Lösung, mit der es möglich ist, den Zeilenindex dynamisch zu machen.

    Beispiel: meine Formel (ausgehend vom Info 2.png

    =WVERWEIS(A23;'Feb 17'!$C$1:AG48;5;FALSCH)

    Der Zeilenindex wäre in diesem Beispiel auf Meier in Zeile 5 bezogen. (Info 1.png)

    Wenn jetzt ein Name dazukommt, der in Zeile 4 steht, wird Meier ja automatisch zu Zeile 6 und somit stimmt der Zeilenindex nicht mehr. Diesen muss ich nun händisch anpassen. Kein Problem wenn das einmal vorkommt aber es kommt eben öfters vor und somit such ich nun eine andere Lösung.

    Ich versuchte es mit einem Sverweis zu lösen, da der Name Meier auch auf dem Sheet vorkommt, von dem der WVERWEIS ausgeht. Hat aber nicht funktioniert.

    Im www habe ich nichts gefunden, mit dem ich was anfangen konnte.

    Kann mir hier jemand helfen?

    Danke im Voraus

    cesar
    Angehängte Grafiken Angehängte Grafiken

  2. #2
    Registriert seit
    21.06.2008
    Ort
    Aargau West
    Beiträge
    817
    Was passiert, wenn du anstatt

    Code:
    =WVERWEIS(A24;'Feb 17'!$C$1:AG48;5;FALSCH)
    Zeile () verwendest:

    Code:
    =WVERWEIS(A24;'Feb 17'!$C$1:AG48;ZEILE(5:5);FALSCH)
    hat mal einen Fujitsu Siemens PC Modell "Xpert" besessen...

  3. #3
    Registriert seit
    19.08.2007
    Beiträge
    72
    Hallo Xpert

    habe ich gemacht, hilft aber nichts. Der Verweis bringt dann Zahlen aus verschiedenen Zeilen. Auch über einen grösseren Bereich, zB: 1-60 bringt nichts, ebenso ein kleinerer Bereich.

    gruss
    cesar

  4. #4
    Registriert seit
    28.02.2010
    Ort
    Grossraum Aarau
    Beiträge
    568
    Hallo cesar

    Ein anderer Lösungsansatz, siehe bitte im Anhang.

    Die Formel in Zelle J18 meines Beispiels:

    Code:
    =INDEX(B2:G9;VERGLEICH(J17;A2:A9;0);VERGLEICH(J16;B1:G1;1))
    Zu Deiner Frage in der Formel mit der Funktion WVERWEIS muss der Zeilenindex berechnet werden z.B. mit der Funktion ZEILE()
    Angehängte Dateien Angehängte Dateien
    Freundliche Grüsse
    Turakos

    Das Forum lebt von den Erfahrungen und den Beiträgen der User – ein Feedback ist wünschenswert.

  5. #5
    Registriert seit
    19.08.2007
    Beiträge
    72

    Hallo Turakos

    Das mit dem Index habe ich auch ausprobiert, hat aber nicht geklappt.

    Aber deine Version ist super. Funktioniert einwandfrei und erfüllt den Zweck hervorragend.

    Herzlichen Dank für die Bemühung

    gruss
    cesar

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Firmenlink