Ergebnis 1 bis 3 von 3
  1. #1
    Registriert seit
    30.04.2011
    Beiträge
    8

    Reden SVerweis funktioniert nicht

    Situation:
    In will in einer Artikeltabelle die Lagerbestände und die Einheiten von einer zweiten Tabelle anzeigen lassen. Das funktioniert aber nicht. Es bringt die Fehlermeldung #NV. Kann mir jemand helfen?
    Ich möchte am Ende ingesamt 4 solche Konstrukte haben, damit Ich den Artikel suchen kann und einen durchschnittlichen Lagerwert erhalte.

    Ich wende die Formel = =SVERWEIS(A2;'561_2017'!A:C;2;0)

    Tabelle 1

    Material Einheit Bestand zum 01.01.2016
    8000343
    8000345
    8000347
    8000348
    8000354
    8000356

    Tabelle 2

    Material Menge in ErfassME ErfassungsMngEinh
    8000343 100.00 M
    8000345 30.00 ST
    8000347 200.00 M
    8000347 2.00 ST
    8000348 100.00 M
    8000348 2.00 ST

    Merci

  2. #2
    Registriert seit
    22.06.2010
    Beiträge
    10
    Hallo suneshi,


    Ohne Beispiel-Datei ist die Ferndiagnose schwierig. Oft hängt der Fehler #NV aber damit zusammen, dass die Zell-Formatierungen nicht in beiden Tabellen identisch sind. Beispielsweise ist die Zelle mit der Materialnummer in der einen Tabelle als "Text" formatiert, in der anderen Tabelle aber als "Zahl". In diesem Fall kann SVERWEIS nichts finden.

    Folgende Möglichkeiten fallen mir spontan ein:

    1. Möglichkeit: Füge in beiden Tabellen eine Hilfsspalte ein: Füge nach Spalte A eine leere Spalte B ein und dort die Formel =A2*1. Ziehe diese Formel herunter. Somit wird auch eine allfällig als Text formatierte Zahl zur "echten" Zahl. Dann beziehst du den SVERWEIS nicht mehr auf Spalte A, sondern auf Spalte B. =SVERWEIS(B2;'561_2017'!B: D;2;0)


    2. Möglichkeit: Verwende statt =SVERWEIS die Funktion =SUMMEWENN. Diese Funktion ist bei der Zellformatierung nicht so wählerisch wie Sverweis. Die Formel würde dann lauten =SUMMEWENN('561_2017'!A:A;A2;'561_2017'!B:B)
    Das funktioniert allerdings nur mit der Menge; die Mengeneinheit kannst du so nicht extrahieren, da sie ja keine Zahl, sondern eine Einheit ist und sich somit nicht addieren lässt.


    Für eine genauere Diagnose hängst du am besten eine Beispiel-Excel-Datei hier an, dann wird das Problem sicher schnell ersichtlich.

  3. #3
    Registriert seit
    28.02.2010
    Ort
    Grossraum Aarau
    Beiträge
    588
    Hallo suneshi

    Wenn die in deinem Post aufgeführte Tabelle 2 der Datenbestand ist aus dem mit SVERWEIS Informationen gelesen werden sollen, funktioniert das nicht, da Artikelnummern (Material) in der Tabelle 2 doppelt aufgeführt sind.

    Ohne dass ich entsprechende Muster-Dateien sehe, vermute ich, dass die Datenstruktur nicht optimal gewählt ist für dein Vorhaben!

    Wenn du Hilfe haben möchtest, stelle bitte deine Daten als Musterdatei zur Verfügung (inklusive Informationen, ob Daten importiert wurden). Ich habe keine Lust die Daten-Dateien nachzubauen!

    Eine andere Möglichkeit wäre Power Query.
    Geändert von Turakos (13.06.2018 um 12:06 Uhr)
    Freundliche Grüsse
    Turakos

    Das Forum lebt von den Erfahrungen und den Beiträgen der User – ein Feedback ist wünschenswert.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •