Firmenlink

 

Calc/Excel: gewichteter Durchschnitt

Problem: Ich möchte gerne einen gewichteten Durchschnitt in OpenOffice.org Calc berechnen. Ich verwende bisher eine etwas komplizierte Formel, die soweit funktioniert (=((15.8333*E3)+(15.8333*I3)+(15.8333*K3)+(15.8333 *M3)+(15.8333*N3)+(15.8333*O3)+(5*G3))/100). Nur sind meine Datensätze teils unvollständig, d.h. es gibt leere Zellen in der Tabelle. Der Durchschnitt soll trotz der leeren Zellen berechnet werden. Muss ich jede Formel separat an die Leerzellen anpassen?

von Gaby Salvisberg 02.02.2011

Lösung: Verwenden Sie zum Berechnen des gewichteten Durchschnitts die Funktionen SUMMENPRODUKT und SUMME.

Berechnet den gewichteten Durchschnitt Berechnet den gewichteten Durchschnitt Zoom Angenommen, die Merkmale stehen in den Zellen A2:A9 und die Ereignisse in den Zellen B2:B9, dann lautet die Formel so:
=SUMMENPRODUKT(A2:A9;B2:B9)/SUMME(A2:A9)

A2:A9 ist hierbei die Matrix 1 (z. B. mit Merkmalen); B2:B9 ist Matrix 2 (z. B. mit gezählten Ereignissen). Matrix 1 wird durch Matrix 2 geteilt. Das Ganze geht natürlich auch in Microsoft Excel. (PCtipp-Forum)

Tags: Excel

    Kommentare

    Keine Kommentare

    Sie müssen eingeloggt sein, um Kommentare zu verfassen.