Firmenlink

 

Excel/Calc: Plus- und Minusspalten

Problem: Ich habe eine Excel-Tabelle mit mehreren Spalten. Eine Spalte für die Kosten, eine fürs Total, eine für Vorauszahlung, eine für Guthaben und die letzte fürs Minussaldo. Wie muss die Formel aussehen, damit nur in der Spalte Guthaben oder Minussaldo eine Summe ist und die jeweils andere leer bleibt?

von Gaby Salvisberg 08.04.2012

Lösung: Die Zahlen könnten eigentlich auch in derselben Spalte stehen. Es wäre ja ersichtlich, wenn es sich um positive oder negative Zahlen handelte.

Unterscheidung positiver/negativer Zahlen Unterscheidung positiver/negativer Zahlen Zoom Aber natürlich können Sie die Zahlen mittels der WENN-Funktion aufteilen, je nachdem, ob es sich um eine positive Zahl (>0) oder negative Zahl (<0) handelt: In der Spalte «Guthaben» wäre es damit diese Formel:
=WENN(C2-B2>0;C2-B2;"")

Und bei Minussaldo diese:
=WENN(C2-B2<0;C2-B2;"")

Die können Sie wie gewohnt in die restlichen Zellen ziehen. Der Tipp gilt auch für OpenOffice.org/LibreOffice Calc. (PCtipp-Forum)

Tags: Excel

    Kommentare

    Keine Kommentare

    Sie müssen eingeloggt sein, um Kommentare zu verfassen.