0"). Leider hat diese Formel einen Schönheitsfehler. Solange die Zellen A1:G1 leer sind, erscheint in der Formelzelle diese Meldung: #DIV/0! Haben Sie mir eine Lösung, um diese Fehlermeldung zu eliminieren?">

 

Excel: Fehlermeldung, wenn Zellen leer

Ich möchte in einer Tabelle einen Notendurchschnitt berechnen mit der Formel =SUMME(A1:G1)/ZÄHLENWENN(A1:G1;">0"). Leider hat diese Formel einen Schönheitsfehler. Solange die Zellen A1:G1 leer sind, erscheint in der Formelzelle diese Meldung: #DIV/0! Haben Sie mir eine Lösung, um diese Fehlermeldung zu eliminieren?

von Antje Küchler 27.04.2006 (Letztes Update: 27.04.2006)

Dass die Fehlermeldung erscheint, ist nachvollziehbar, denn "#DIV/0!" heisst in der Sprache von Excel, Sie wollen hier eine Division durch Null vornehmen, was mathematisch nicht erlaubt ist.

Also müssen Sie zuerst einmal abfragen, ob die Zellen A1 bis G1 leer sind, bevor Sie die Berechnung in der von Ihnen gewünschten Form vornehmen können.

Eine Möglichkeit, das abzufragen, stellt die Excel-Funktion WENN bereit. Das sieht dann so aus:

=WENN(SUMME(A1:G1)>0;SUMME(A1:G1)/ZÄHLENWENN(A1:G1;">0");"")

    Zoom

Der "Innenteil" Ihrer Formel bleibt also im Prinzip gleich, aber es wird noch eine WENN-Abfrage vorgeschaltet, die erst einmal sicherstellt, dass die Berechnung nur ausgeführt wird, wenn zumindest in einer Zelle ein Wert steht, der grösser Null ist, wenn also keine Division durch Null zu befürchten ist.

Ist die Summe der Zellen A1 bis G1 grösser als Null, wird die Berechnung durchgeführt, und falls die Summe der Zellen A1 bis G1 Null ist, die Zellen also in diesem Falle leer sind, kommt es gar nicht erst zu einer Berechnung und damit auch zu keiner Fehlermeldung. Die Ergebniszelle bleibt dann leer.


    Kommentare

    Keine Kommentare

    Sie müssen eingeloggt sein, um Kommentare zu verfassen.