Firmenlink

 

Excel meldet «Mit dieser Formel gibt es ein Problem»

Sie wollen eine Formel übernehmen, die Ihnen ein Kollege gemailt hat. Aber Excel meint, es gebe ein Problem und bezweifelt gar frech Ihre Absicht, eine Formel einzugeben.

von Gaby Salvisberg 23.09.2016

Die Fehlermeldung, die Excel Ihnen entgegenhält, wirkt kurios und wenig hilfreich, wenn Sie versuchen, die Formel aus der Mail in Ihr Excel-Blatt zu kopieren. Im vollen Wortlaut heisst es da: «Mit dieser Formel gibt es ein Problem.» Dann wird ernsthaft Ihre Absicht angezweifelt: «Sie möchten gar keine Formel eingeben?» Und dann folgt die Belehrung: «Wenn das erste Zeichen ein Gleichheitszeichen (=) oder Minuszeichen (-) ist, hält Excel Ihre Eingabe für eine Formel.»

Die Formel selbst enthält eigentlich nur normale Operationen, zum Beispiel so etwas mit ZÄHLENWENN: =ZÄHLENWENN($C$17:$C$47,"Ferien"). Ihr Kollege kann Ihnen auch nicht helfen, denn er behauptet steif und fest, dass die Formel bei ihm funktioniere. Was ist denn da los?

Lösung: Falls die Formel Kommas enthält (wie hier vor "Ferien"), dann ersetzen Sie diese doch einmal probehalber durch Strichpunkte: =ZÄHLENWENN($C$17:$C$47;"Ferien"). Oder umgekehrt: Ersetzen Sie mal die Strichpunkte durch Kommas. Ziemlich sicher wird es damit funktionieren. 

Aber die Ursache haben Sie noch nicht behoben: Excel orientiert sich standardmässig daran, welches Listentrennzeichen im System eingestellt ist. Wenn es das Komma ist (wie z.B. im US-Sprachschema), dann erwartet Excel auch in der Formel ein Komma. Wenn es das Semikolon (Strichpunkt) ist, muss auch die Formel hier mit Strichpunkten aufwarten.

Prüfen Sie einmal die Einstellungen via Systemsteuerung/Zeit, Sprache und Region/Region und Sprache. Falls das Format stimmt (z.B. «Deutsch (Schweiz)», klicken Sie auf Weitere Einstellungen. Unter «Format anpassen» im Reiter Zahlen finden Sie nun unter anderem das Listentrennzeichen. Ist es das richtige? Passen Sie es gegebenenfalls an oder bitten Sie den Kollegen, die Einstellung bei sich nochmals zu prüfen. Oder Sie denken einfach jeweils daran, das Zeichen zu ersetzen.

In Excel kann man die automatische Übernahme der Zahlenformate auch deaktivieren und anstelle der systemweiten Standards zum Teil separate Einstellungen setzen. Schauen Sie auch in Excel selbst einmal nach: Datei/Optionen/Erweitert. Dort gibts unter «Bearbeitungsoptionen» einen Punkt «Trennzeichen vom Betriebssystem übernehmen». Aktivieren Sie diese, falls nicht so eingestellt.

Tags: Excel

    Kommentare

    Keine Kommentare

    Sie müssen eingeloggt sein, um Kommentare zu verfassen.