Firmenlink

 

Excel: Soll man die 1904-Datumswerte nutzen?

Problem: Wenn ich in Excel z.B. meine Trainingszeiten-Differenzen berechnen will, erscheinen bei negativen Zahlen nur Rautensymbole (#####). Wenn ich die 1904-Datumswerte verwende (siehe Artikel 22238), dann klappt das besser. Allerdings habe ich schon gehört, dass das zu Problemen führen kann. Kann mir jemand sagen, wie ich diese negativen Zeiten richtig einrichten muss?

von Gaby Salvisberg 16.07.2008

Lösung: Tatsächlich «scheint» das Rechnen mit negativen Zeiten auf den ersten Blick besser zu klappen, wenn man die 1904-Datumswerte aktiviert.

Allerdings kann das sehr grosse Nachteile haben. Excel kann auch so mit negativen Zeitwerten rechnen. Die im erwähnten Artikel genannten 1904-Datusmwerte sind nicht zu empfehlen. Damit handelt man sich wesentlich mehr Nachteile ein, denn es verschieben sich damit alle bereits in der Mappe erfassten Datumswerte um 4 Jahre und 1 Tag!

Die Ursache dafür ist die Art und Weise, wie Excel Datums- und Zeitwerte speichert. Formatiert man eine Datumszelle als 'Standard', erhält man z.B. für das Datum 10.07.2008 normalerweise die Zahl 39639 - das ist die Anzahl vergangener Tage seit dem 0(!).1.1900 fortlaufend gezählt.
Werden nun die 1904-Datumswerte gesetzt, dann bleibt dieser Wert in den Zellen erhalten. Das ist natürlich korrekt, aber der Beginn der Zeitrechnung von Excel wird dann auf den 1.1.1904 gelegt. So steht dann, formatiert man die Zelle wieder als Zahl, der 11.07.2012 in der Zelle - eine Verschiebung um 4 Jahre und 1 Tag.
Dies geschieht ohne Warnung oder Hinweis und bleibt in der ersten Zeit normalerweise unbemerkt.

Wenn dann diese Daten mit solchen in anderen Mappen verglichen werden, in denen die Option nicht gesetzt ist, kommt diese Verschiebung auch dann zum Tragen. Genauso, wenn Datumswerte zwischen Mappen mit unterschiedlich gesetzter 1904-Option hin und her kopiert werden.

Verzichten Sie darum auf die 1904-Datumswerte. Führen Sie stattdessen lieber eine zweite Spalte, in der diese negativen Werte als normale positive geführt und dann miteinander verrechnet werden.

Das kann dann wie folgt aussehen:

Keine 1904-Datumswerte nötig: Mit den richtigen Formeln gehts. Keine 1904-Datumswerte nötig: Mit den richtigen Formeln gehts. Zoom

A

B

C

1

Dauer

Plus-Differenz

Minus-Differenz

2

04:50

3

05:02

00:12

4

04:58

00:04

5

04:25

00:33

6

05:00

00:35

Die verwendeten Formeln, die sich dann in die weiteren Zellen kopieren lassen:
In B3 steht die Formel =WENN(A3>A2;A3-A2;"")
In C3 steht die Formel =WENN(A3<A2;A2-A3;"")
Zellen A2:C6 sind als hh:mm formatiert

Dann brauchen Sie keine Angst zu haben, wenn Sie die Daten aus dieser Arbeitsmappe mit anderen Daten zusammenführen. (PCtipp-Forum)

Tags: Excel

    Kommentare

    Keine Kommentare

    Sie müssen eingeloggt sein, um Kommentare zu verfassen.