Ergebnis 1 bis 4 von 4
  1. #1
    Registriert seit
    29.08.2007
    Beiträge
    164

    EXCEL Formelergebnis 0

    Hallo Zusammen

    In einem Tabellenblatt habe ich folgende Formel in Zelle I2, sowie entsprechend angepasst in den Folgezellen der Spalte I.

    =WENN($E2="Herr";1;WENN(E2="Frau";1;2))

    Je nachdem wie oft "Herr" und/oder "Frau" vorkommt soll die Zahl ausgegeben werden, also 1 oder 2. Wenn die Zellen in E, also im Beispiel E2 leer ist, wird troztdem 2 ausgegeben. Da ich am Schluss diese Werte summiere, ergibt sich so ein falsches Summetotal. ( In den Zellen der Spalte E kann es nur maximal nur zwei Wörter geben, Herr + Frau; Frau + Frau; Herr + Herr, Herr / Frau allein.)

    Wie muss ich die Formel ergänzen um im Falle von leerem E2 den Wert leer in I2, also eine leere Zelle zu bekommen? Nun wirklich leer ist die Zelle natürlich nicht, es steht ja noch die Formel drinn.

    Alternativ kann die Formel auch so ergänzt werden, dass sie den Werte Leer ausgibt, wenn die Zelle in Spalte D, also in obigem Beispiel D2 leer ist.

    Schon mal herzlichen Dank für die Hilfe und beste Grüsse
    Smily44

  2. #2
    Registriert seit
    04.08.2015
    Ort
    in der Geburtsstadt der Gebrüder Grimm
    Beiträge
    206

    Excelformeln.de hilft

    Hallo Smily,

    bei Excelformeln.de habe ich was tolles gefunden. Wenn du alle "Herr" in Spalte E aufsummieren willst, geht das so:
    Code:
    =SUMME((LÄNGE(E:E)-LÄNGE(WECHSELN(E:E;"Herr";"")))/LÄNGE("Herr"))
    Das ist eine Array-Formel. Du musst die Eingabe mit Umschalt+Strg+Eingabe abschließen.

    Grüße, Andreas

  3. #3
    Registriert seit
    28.02.2010
    Ort
    Grossraum Aarau
    Beiträge
    614
    Grüezi smily

    basierend auf einer Ergänzung deiner Formel in Spalte I:

    =WENN($E2="";"";WENN($E2="Herr";1;WENN($E2="Frau"; 1;2)))
    Freundliche Grüsse
    Turakos

    Das Forum lebt von den Erfahrungen und den Beiträgen der User – ein Feedback ist wünschenswert.

  4. #4
    Registriert seit
    29.08.2007
    Beiträge
    164
    Hallo Andreas,
    Hallo Turakos,
    Vielen Dank für eure Hinweise.

    Zum Input von Andreas
    Es geht mir nicht darum zu wissen wie viele Herr oder Frau an Bord sind, sondern in einer Spalte die Anzahl Personen in der Kabine zu zählen. Diese Summer wird im weiteren Verlauf z.B. für die Verwaltug der Teilnahme an Ausflügen gebraucht, um den zu zahlenden Preis zu ermittlen und korrekt den Gästen zuweisen zu können.

    Zum Input von Turakos
    Das ist genau die Ergänzung die gesucht habe. Ich habe den ersten Zellhinweis von $E2 auf $D2 abgeändert und habe nun perfekt das was ich wollte. Die leeren Zellen in Spalte D sind präzieser als in E um das zu steuern.

    Nochmals vielen Dank an euch beide und einen schönen Abend.
    Beste Grüsse
    Smily44

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •