Excel: eingetippte Zahl in Minuszahl verwandeln

Beim Erfassen von Ausgaben wollen Sie das Minuszeichen nicht eintippen müssen, weil Sie es eh oft vergessen. Die simple Lösung liefert die Mathematik.

von Gaby Salvisberg 28.01.2019

Sie erfassen in Excel Einnahmen und Ausgaben in derselben Spalte. Weil Sie bei Ausgaben das Minuszeichen oft vergessen, soll Excel die Zahlen in der eigentlichen Berechnungsspalte korrekt übernehmen – mit Minuszeichen bei Ausgaben.

Angenommen, Sie wählen in Spalte A, ob es sich um eine Einnahme oder eine Ausgabe handelt. In Spalte B tippen Sie die Beträge ein, wobei Sie in Zukunft bei Ausgaben auf die Eingabe des Minuszeichens verzichten wollen. Excel soll die Zahlen korrekt in die Spalte C schreiben, nämlich mit Minuszeichen vor der Zahl, sofern es eine Ausgabe ist.

Verwenden Sie in Spalte C (z.B. in C2) diese Formel und ziehen Sie sie herunter:

=WENN(A2="Ausgabe";ABS(B2)*-1;B2)

Die tut Folgendes: «Wenn in A2 'Ausgabe' steht, nimm die absolute Zahl (ABS) aus B2 und multipliziere sie mit «-1» (um sie auf negativ zu drehen); in allen anderen Fällen (wenn nicht 'Ausgabe' steht), nimm einfach die Zahl aus B2». Die absolute Zahl bedeutet die alleinige Zahl, unabhängig davon, ob sie positiv oder negativ ist. +7 wird damit gleich behandelt wie -7. Es spielt also überhaupt keine Rolle, ob Sie die Zahl bei Ausgaben positiv oder negativ eintippen.

Falls Sie in Spalte B die Zahlen künftig trotzdem konsequent «positiv» haben wollen, lassen Sie sich warnen, falls doch mal aus Versehen ein Minuszeichen in der Zelle landet. Markieren Sie den betroffenen Zellbereich in Spalte B. Gehen Sie zu Daten/Datentools/Datenüberprüfung. Wählen Sie bei Zulassen den Eintrag Benutzerdefiniert. Als Formel geben Sie ein =B2:B11>0 und passen hier natürlich den Zellbereich dem tatsächlichen Bereich an.

Das funktioniert in LibreOffice Calc und anderen Tabellenkalkulationen alles ebenfalls sinngemäss. (PCtipp-Forum)


    Kommentare

    • karnickel 02.02.2019, 10.24 Uhr

      Also ich hätte eine bedingte Formatierung genommen, um andersherum das Minuszeichen zwar eingeben zu müssen, dafür aber ohne Arbeit den Text "Ausgabe" geschenkt zu bekommen. ;) Zusätzlicher Spasseffekt dabei wäre dann, nur eine Zahlenspalte zu haben, was aus meiner Sicht viel schöner aussehen würde. Chacune à son gout. ;)

    weitere Kommentare

    Sie müssen eingeloggt sein, um Kommentare zu verfassen.