Firmenlink

ESET

 

Excel: Zahl in Formel direkt runden

Wie erwischen Sie in einer Excel-Formel nicht nur «500», sondern auch alles, was geringfügig grösser oder kleiner ist?

von Gaby Salvisberg 31.07.2019

Sie haben in Excel oder LibreOffice Calc eine Reihe von Zahlen, mit denen Sie etwas anstellen wollen. 

Vielleicht soll überall die Zahl 500 markiert oder durch ein X gekennzeichnet werden. Das wäre ja noch einfach. Zum Beispiel, wenn die Zahlen in Spalte A stehen, könnte die Formel in Spalte B (angefangen mit B2) so lauten:
WENN(A2<>500;"";"X")

Was etwa heisst: Wenn die Zahl in A2 grösser oder kleiner als 500 ist, dann schreibe nichts (""), ansonsten schreibe "X". Und dieses «Ansonsten» trifft logischerweise all jene Fälle, in denen die Zahl genau 500 entspricht. 

Nun haben Sie aber in Spalte A vielleicht Zahlen mit Kommastellen. Sie wollen nicht nur genau 500 erwischen, sondern auch ungefähr 500, nämlich auch 499.99 oder 500.01. 

Wie genau hätten Sie es denn gern?

Hier kommt die Rundungsfunktion zum Einsatz, die Sie auch sehr bequem direkt in eine andere Formel einbauen können. Sie heisst erfreulicherweise auch schlicht RUNDEN und funktioniert nach diesem Schema: RUNDEN(Ausgangszahl oder -zelle; Anzahl Stellen). 

Hier wird zum Beispiel die Zahl aus A2 auf zwei Stellen gerundet, bevor die WENN-Funktion damit rechnet:
=WENN(RUNDEN(A2;2)<>500;"";"X")

Sie können auch auf null Stellen runden: RUNDEN(A2;0), wenn Sie es noch etwas weniger genau haben wollen. Dasselbe funktioniert in LibreOffice oder OpenOffice Calc übrigens genau gleich.


    Kommentare

    Keine Kommentare

    Sie müssen eingeloggt sein, um Kommentare zu verfassen.