Tipps & Tricks 01.12.2003, 20:00 Uhr

Excel Lieferdatum berechnen

Ich möchte in einer Excel-Datei folgendes berechnen: Am 31.08.2003 wird eine bestimmte Ware geliefert. Lieferbedingung ist Zahlungseingang 35 Tage vor Liefertermin (Anzeige in Tabelle = Zahlungstermin) Bedingung: Bestellung erfolgt in weniger als 35 Tagen vor Liefertermin (Anzeige in Tabelle = Sofortige Zahlung). Welche Formel muss ich hierfür anwenden?
Sie können dieses Problem folgendermassen lösen:
In der ersten Spalte (A) geben Sie das Bestelldatum ein, in der zweiten Spalte (B) das Lieferdatum. In der dritten Spalte (C) wird ausgerechnet, ob das Lieferdatum mehr als 35 Tage nach dem Bestelldatum liegt. Falls dies der Fall ist, wird das Datum ausgegeben, bis zu dem die Zahlung spätestens erfolgen muss. Liegt das Bestelldatum in einem Abstand von weniger als 35 Tagen, wird die Meldung "Sofortige Zahlung" ausgegeben.
Hier in dem Screenshot sehen Sie in Zelle C2 die Formel:
=WENN(B3-A3>35;B3-35;"Sofortige Zahlung")
Das bedeutet, der 35. Tag wird noch nicht berücksichtigt, erst der 36.
Natürlich können Sie die Formel auch so abfassen, dass der 35. Tag mit abgefragt wird, entweder indem Sie die Formel so gestalten:
=WENN(B3-A3>=35;B3-35;"Sofortige Zahlung")
oder auch umgekehrt
=WENN(B3-A3<=35;"Sofortige Zahlung";B3-35)
Das bleibt ganz Ihnen überlassen.
In diesem Beispiel haben wir die Zellen auch noch mit einer "Bedingten Formatierung" versehen. So werden die Datumsangaben, die sich noch im "grünen Bereich" befinden, mit grün hinterlegt und diejenigen, bei denen die Grenze von 35 Tagen bereits überschritten ist, mit rot.
Um die bedingte Formatierung einzugeben rufen Sie das Menü "Format" und dann den Menüpunkt "Bedingte Formatierung" auf und geben die folgenden Bedingungen ein:
Über die Knöpfe "Format" wählen Sie dann die Farben des Hintergrundes und der Schrift aus, die erscheinen sollen, wenn die Bedingung erfüllt ist.
Zu "Bedingte Formatierung" lesen Sie mehr hier nach: [1]
Damit ist eigentlich schon alles getan. Wenn Sie die Formel mit "AutoAusfüllen" so weit in der ganzen Spalte hinunterziehen, wie Sie es benötigen, wird auch die bedingte Formatierung gleichzeitig auf alle mit der Formel ausgefüllten Zellen übertragen.
Wenn Sie jedoch noch eine weitere Information automatisch in Ihrer Liste ablesen wollen, nämlich ob ein Kunde, der vor mehr als 35 Tagen bestellt hat, mittlerweile mit der Zahlung in Verzug ist, können Sie auch noch eine zweite Abfrage einbauen, diese hier:
Die Formel =WENN(B2-HEUTE()<=35;"Zahlungserinnerung";"") sagt aus, dass bei jedem Aufruf Ihrer Liste geprüft wird, ob das heutige Datum weniger als 35 Tage vom Lieferdatum entfernt ist. Ist das der Fall, wird der Text "Zahlungserinnerung" in der Zelle D2 ausgegeben. Ist der Abstand von 35 Tagen noch nicht unterschritten, bleibt das Feld leer. Um das Feld gelb zu hinterlegen, ist wiederum eine bedingte Formatierung vorhanden, bei der abgefragt wird: "Zellwert ist gleich "Zahlungserinnerung"". Falls ja, wird das Feld gelb.
Wollen Sie die Kunden, bei denen zwar die Zeit überschritten ist, die jedoch bereits bezahlt haben, von dieser gelben Anzeige ausschliessen, müssen Sie noch eine weitere Spalte einfügen, die Spalte "Bezahlt". Gehen wir einmal davon aus, dass die Spalte "Bezahlt" die Spalte E Ihres Excel-Tabellenblattes ist, dann würde sich die Formel in Spalte D folgendermassen ausnehmen:
=WENN(UND(B2-HEUTE()<=35;E2="erledigt");"";"Zahlungserinnerung")
Sobald der Kunde bezahlt hat und Sie das Wort "erledigt" in der Spalte E eingetragen haben, wird in Spalte D keine "Zahlungserinnerung" mehr angezeigt.
Zur WENN-Funktion verschachtelt mit der UND-Funktion, wie hier angewendet, können Sie genauer noch einmal hier nachlesen: [2]
So behalten Sie immer den Überblick: Grüne Felder sind noch nicht fällig, rote müssen sofort zahlen und gelbe sind überfällig.


Kommentare

Es sind keine Kommentare vorhanden.