Firmenlink

ESET

 

Excel: Unentbehrliche Tricks für Ihre Geburtstagsliste

Wer hat als nächstes Geburtstag? Wie alt werden die Leute am nächsten Geburtstag? Und wer hat einen Runden? Antworten im Artikel.

von Gaby Salvisberg 25.04.2019

Geburtstagslisten sind beliebte Excel-Objekte. Nur gibt es ein paar Probleme zu umschiffen, die einem erst begegnen, wenn man tatsächlich mit einer solchen Liste arbeitet. Manche betreffen die Sortierung, manche betreffen die Tatsache, dass Geburtstage fürs aktuelle Jahr auch schon wieder vorbei sein können.

«Geburtstag» ist nicht «Alter»: Meistens haben Sie die Geburtsdaten inkl. Jahrgang in Ihrer Liste. Wenn Sie diese Liste schlicht per Klick aufs Sortieren-Icon nach diesen Daten sortieren, dann haben Sie nicht nach Datum, sondern nach Alter sortiert. Die Zeilen erscheinen nicht in der Reihenfolge der Geburtstage, sondern die älteste Person zuoberst, die jüngste zuunterst. Das ist aber meist nicht der Zweck einer Geburstagsliste.

Mit dieser Sortierung finden Sie nicht heraus, in welcher Reihenfolge die Leute verschiedenen Alters Geburstag haben Mit dieser Sortierung finden Sie nicht heraus, in welcher Reihenfolge die Leute verschiedenen Alters Geburstag haben Zoom© pctipp.ch

Es gäbe hierfür die Möglichkeit, mit einer Hilfsspalte zu arbeiten, die Monat und Tag aus dem Datum ausliest. Wenn man nach dieser sortiert, stimmt die Reihenfolge der Geburtstage wieder, siehe «Liste nach Geburtstag sortieren, nicht nach Alter». Aber wir haben da eine noch bessere Idee, denn: Wenn schon eine Hilfsspalte, warum dann nicht gleich eine so richtig nützliche?

Wann sind die nächsten Geburtstage? Ermitteln Sie, wann die nächsten Geburtstage auf Ihrer Liste stattfinden – und zwar inkl. Wochentag. Hierfür brauchen wir eine etwas längere Formel. In Spalten A und B haben wir die Namen und Vornamen, in Spalte C haben wir die Geburtsdaten. In Spalte D wollen wir jetzt mit folgender Formel wissen, wann jede Person den nächsten Geburtstag hat. Fügen Sie diese Formel in D2 ein und ziehen Sie diese herunter:

=WENN(DATUM(JAHR(HEUTE());MONAT(C2);TAG(C2))<HEUTE();DATUM(JAHR(HEUTE())+1;MONAT(C2);TAG(C2));DATUM(JAHR(HEUTE());MONAT(C2);TAG(C2)))

Lassen Sie sich nicht irritieren, falls zunächst nur Zahlen wie «43707» erscheinen. Das beheben wir gleich.

Was macht diese Formel? Die oben gezeigte WENN-Formel besteht wie immer aus drei Teilen, sinngemäss: «=WENN(das zutrifft;dann mach dies;sonst mach jenes)». Der erste Teil DATUM(JAHR(HEUTE());MONAT(C2);TAG(C2))<HEUTE() prüft, ob eine Person dieses Jahr schon Geburtstag hatte. Der zweite Teil DATUM(JAHR(HEUTE())+1;MONAT(C2);TAG(C2)) wird verwendet, wenn die erwähnte Prüfung zutrifft; denn in diesem Fall wird nicht das diesjährige (bereits vergangene) Geburtsdatum genommen, sondern jenes vom nächsten Jahr (hierfür das «+1»). Der dritte ist der «sonst»-Teil DATUM(JAHR(HEUTE());MONAT(C2);TAG(C2))), der in allen anderen Fällen zum Zuge kommt.

Die Zellen müssen noch formatiert werden Die Zellen müssen noch formatiert werden Zoom© pctipp.ch

Zunächst erscheinen nur Zahlen (z.B. 43707). Markieren Sie die Spalte, klicken Sie mit rechts drauf und wählen Sie Zellen formatieren. Sie könnten natürlich unter Kategorie zu Datum greifen und dort eins der Formate auswählen. Aber eleganter wäre doch ein Format, das auch den kurzen Wochentag anzeigt. Wählen Sie darum bei der Kategorie Benutzerdefiniert und tippen Sie bei Typ manuell dieses Format ein: TTT TT.MM.JJJJ. Klicken Sie auf OK.

Mit diesem Zellformat zeigt Excel auch den Wochentag Mit diesem Zellformat zeigt Excel auch den Wochentag Zoom© pctipp.ch

Ab sofort sortieren Sie die Liste nicht mehr nach dem Geburtsdatum, sondern nach der Spalte Nächster Geburtstag. Und schon stimmt die Reihenfolge wieder.

So sieht die sortierte Liste aus, wenn Sie diese nach dem nächsten Geburtstag sortieren So sieht die sortierte Liste aus, wenn Sie diese nach dem nächsten Geburtstag sortieren Zoom© pctipp.ch

Lesen Sie auf der nächsten Seite: Wie alt wird die Person? Wer hat einen «Runden»?

Seite 1 von 2
       
       

    Kommentare

    • DaTorre 26.04.2019, 09.44 Uhr

      Interessanter Artikel zur Darstellung von Geburtstagslisten mit Excel. Offenbar funktioniert die Formel nur bis zum Jahr 1900 zurück. Mit welcher Formel können auch Jahrgänge vor 1900 in die Liste aufgenommen werden (z.B. für Jubiläen bekannter Persönlichkeiten (z.B. Alfred Escher, geb. am 20.02.1819; Theodor Fontane, geb. am 30.12.1819; Queen Victoria Alexandrina, geb. am 24.05.1819 usw.)? Danke für Tipps.

    weitere Kommentare

    Sie müssen eingeloggt sein, um Kommentare zu verfassen.