Tipps & Tricks 07.11.2006, 10:15 Uhr

Excel-Berechnungen abhängig vom Körpergewicht

Für ein kleines Anästhesie-Programm möchte ich die zu verabreichende Flüssigkeitsmenge pro Stunde nur durch Eingabe des Körpergewichts in Excel berechnen lassen, komme aber mit der Formel dafür nicht klar. Die Aufgabe: Für die ersten 10 Kilogramm Körpergewicht müssen pro kg 4ml berechnet werden, für die zweiten 10kg zusätzlich 2ml/kgKG und ab 20kg zusätzlich noch 1ml/kgKG. Beispiel: Für einen Patienten von 75kg würde dies bedeuten: Für die ersten 10kg x 4ml = 40ml plus für die zweiten 10kg x 2ml = 20ml plus für die restlichen 55kg je 1ml = 55ml. Dies ergibt ein Total von 115ml/Stunde. Können Sie mir mit einer Formel weiterhelfen?
Das ist sehr einfach. Sie müssen das, was Sie hier in Ihrer Anfrage mit Worten beschrieben haben, nur noch in die "Sprache" von Excel umsetzen: Es gibt drei Bedingungen, die miteinander verknüpft werden müssen: Körpergewicht bis 10kg, 11-20kg und über 20kg. Für jeden dieser drei Fälle gibt es eine separate Berechnung, wobei der erste Fall der einfachste ist, denn hier wird das Körpergewicht einfach mit 4 multipliziert. Die komplette Formel lautet dann also:
=WENN(D4>F1;D1*D2+(E1-1)*E2+(D4-F1);WENN(UND(D4>D1;D4<=F1);D1*D2+(D4-D1)*2;D4*D2))
Um die Darstellung der Zellen E1 und F1 wie im Screenshot zu erhalten, tragen Sie einfach ein benutzerdefiniertes Zahlenformat ein. In E1 steht die Zahl 11, und damit Excel in der Zelle "11-20" darstellt, lautet das benutzerdefinierte Format:
#"-20"
Der Text "-20" wird einfach an die Zahl 11 angehängt - nur für die Darstellung, wohlgemerkt.
Ähnliches gilt für F1, hier wird das Grösser-als-Zeichen der Zahl 20 vorangestellt:
">"#
Somit können Sie mit den Zellen E1 und F1 rechnen, da in Wirklichkeit nur die Zahlen 11 und 20 darin enthalten sind.


Kommentare

Es sind keine Kommentare vorhanden.