Tipps & Tricks 04.01.2005, 21:00 Uhr

Excel: WENN – DANN — WENN – DANN – SONST

In der Zelle A2 soll der Wert von A1 erscheinen. Wenn der Wert in Zelle A1 aber grösser als -20 respektive grösser als +8 ist, soll der Wert auf -20 respektive +8 «begrenzt» werden. Ich versuchte es mit einer WENN-Funktion: =WENN(A1>=8;8;A1;WENN(A1>=-20;-20;A1)). Leider funktioniert dies nicht, es habe zu viele «Argumente». Wissen Sie vielleicht Rat?
Ihre Formel enthält zwei logische Fehler. Zuerst einmal ist -20 als negativer Wert mathematisch betrachtet grösser als beispielsweise -21, oder umgekehrt ist -21 kleiner als -20. Sie können das an dieser Grafik sehr gut erkennen.
Die aufsteigende Richtung im Koordinatensystem geht nach rechts. Jede Zahl, die rechts von einer anderen Zahl steht, ist also grösser als diese. 4 ist grösser als 3, aber -3 ist grösser als -4.
In Ihrem Beispiel dürfen Sie also nicht abfragen, ob A1 grösser als -20 ist, sondern Sie müssen fragen, ob A1 kleiner als -20 ist. Somit darf Ihre Abfrage nicht lauten "WENN(A1>=-20 ...)", sondern "WENN(A1<=-20;-20;A1)".
Der zweite logische Fehler ist ein Syntaxfehler in Ihrer WENN-Formel. So, wie Sie es aufgeschrieben haben, hat Ihre Formel zwei "Sonst"-Parameter, sie darf aber nur einen haben - und das ist die zweite WENN-Funktion. Zuerst wird geprüft, ob A1 grösser als 8 ist. Ist das der Fall, wird die Zahl 8 ausgegeben, wenn das nicht der Fall ist, dann wird eine zweite Prüfung durchgeführt: die Abfrage, ob A1 kleiner als -20 ist. Wenn das zutrifft, dann wird -20 ausgegeben, ansonsten soll der Wert von A1 ausgegeben werden.
Somit sieht die richtige Formel für Ihren Fall so aus:
=WENN(A1>=8;8;WENN(A1<=-20;-20;A1))
Auf die Art und Weise lassen sich noch weitere Bedingungen bzw. WENN-Funktionen verschachteln, indem der "Sonst"-Parameter einfach eine weitere WENN-Funktion enthält.

Kommentare

Es sind keine Kommentare vorhanden.