Tipps & Tricks 05.04.2003, 11:45 Uhr

Excel: Werte in einer Matrix suchen

Ich habe in Excel zwei Spalten, die Zeilen gehen von 1 bis 3000. Ich möchte nun, dass Excel mir in einer dritten Spalte «Wahr» oder «Falsch» anzeigt, indem es z.B. die Zelle A1 mit den Werten in B1 bis B3000 vergleicht, ob der Wert von A1 in der B-Spalte enthalten ist.
Mit der Funktion VERGLEICH können Sie prüfen, ob ein Wert in einer Matrix vorhanden ist; sie gibt u.a. die erste Position des Wertes zurück. Wenn Sie nur wissen wollen, ob der Wert vorhanden ist oder nicht (nicht, welche Position er hat), dann betten Sie diese Funktion in eine WENN-Abfrage ein. Da die Funktion VERGLEICH einen Fehlerwert ausgibt, wenn keine Übereinstimmung gefunden wurde, fragen Sie mittels ISTFEHLER nach diesem Fehlerwert. Da jedoch ISTFEHLER ein FALSCH liefert, wenn der Wert vorhanden ist, benötigen Sie die WENN-Funktion, um statt des verwirrenden FALSCH ein WAHR auszugeben. Die fertige Formel sieht dann so aus:
=WENN(ISTFEHLER(VERGLEICH(A1;B1:B3000;0));"Falsch";"Wahr")

Kommentare

Es sind keine Kommentare vorhanden.