SUMMEWENN reicht nicht 24.01.2022, 08:00 Uhr

Excel/LibreOffice: Summe zwischen zwei Kalenderdaten

Aus einer Liste möchten Sie alle Beträge zwischen zwei Kalenderdaten addieren. Das klappt mit diesem Tipp.
In Excel die Summe zwischen zwei Kalenderdaten berechnen
(Quelle: PCtipp.ch)
Sie haben in einer Excel- oder LibreOffice-Tabelle in Spalte B Kalenderdaten und in Spalte C Beträge. Nun möchten Sie alle Beträge zwischen zwei frei wählbaren Kalenderdaten addieren. Aus einem Bauchgefühl würden Sie zu SUMMEWENN greifen, ähnlich wie in diesem Tipp. Nur klappt das nicht.
Lösung: Es funktioniert aber, wenn Sie zum ähnlichen, aber flexibleren SUMMEWENNS greifen, das auch mehrere Kriterien prüfen kann. In unserem Fall müssen die Beträge ja sowohl grösser oder gleich Datum1 sein, als auch kleiner oder gleich Datum2.
Angenommen, die zu addierenden Beträge stehen in C2 bis C600, die zu prüfenden Kalenderdaten in B2 bis B600. In F1 steht das «Von»-Datum, in F2 das «Bis»-Datum. In F3 möchten wir nun alle Beträge addieren, die zwischen den beiden Daten liegen. Greifen Sie zu dieser Formel:
=SUMMEWENNS(C2:C600;B2:B600;">="&F1;B2:B600;"<="&F2)
Mit SUMMEWENNS lassen sich mehrere Kriterien verbinden
Quelle: PCtipp.ch
Hinweis: Beachten Sie, dass wir statt nur > und < die Grösser-gleich- und Kleiner-gleich-Varianten >= und <= verwenden, damit es die Zahlen inklusive der erwähnten Von-Bis-Zeiträume addiert. (PCtipp-Forum)



Kommentare

Avatar
Turakos
24.01.2022
Hallo Gaby Weitere Möglichkeit des Umsatzes zwischen zwei Kalenderdaten mit einer Pivot-Tabelle. Freundliche Grüsse Turakos

Avatar
Mano58
25.01.2022
Hallo Gaby Da reicht der SUMMEWENN()-Befehl völlig: =SUMMEWENN((B2:B600>=F1)* (B2:B600<=F2)*(C2:C600))