Tipps & Tricks 22.01.2015, 07:00 Uhr

Excel: automatischer Kalender für Winterdienst

Der Winter ist zwar schon in vollem Gange, aber der nächste kommt bestimmt. Sind Sie zu dritt und sollen sich wöchentlich beim Schneeschippen abwechseln? Oder beim Rasenmähen, Laubblasen (bewahre!), Treppenhauswischen?
Lösung: Im Beispiel sind die Tage der Monate von Dezember 2014 bis März 2015 aufgelistet. Den Winterdienst (sprich: Schneeschippen) teilen sich hier drei Leute untereinander auf, von denen jeder eine Woche lang auf Wetterglück hoffen und dann die Schneeschippe dem Nächsten vor die Türe stellen darf.
Für dieses Problem muss man mit den Wochen arbeiten. Wenn es nur innerhalb eines Jahres wäre, würde man mit KALENDERWOCHE() rechnen. Da der Kalender aber übers Jahresende hinausgeht, muss man die Wochen anders berechnen. Im vorliegenden Beispiel tun wir dies, indem wir das Datum durch 7 dividieren und das Ergebnis als Ganzzahl ausgeben. Sie könnten hier auch AUFRUNDEN() oder ABRUNDEN() benutzen (aber eher nicht «RUNDEN()»).
In A3 steht das Datum 01.12.2014. Das ist für Excel der 41'974. Tag seit dem 1.1.1900. Dividiert man dieses Datum durch 7, ergibt das 5996.29. Mit GANZZAHL() abgerundet also die Woche 5996. Wers ganz genau nimmt: Die Woche vom 1.1.1900 ist dabei die Woche 0, aber das spielt hier keine Rolle.
Jetzt die Krux mit dem Wochenstart. Damit die gleiche Woche von Sonntag bis Samstag ausgegeben wird, verwenden wir in der Formel GANZZAHL((A3-1)/7) das (A3-1). Damit hätte man für jede Woche (von So bis Sa) die gleiche Wochenzahl: also vom 01.12.2014 bis zum 06.12.2014 die Woche 5996. Vom 7.12. bis zum 13.12.2014 die Woche 5997 etc.
Die Beispiel-Tabelle zum Nachbauen
Nun muss man die Wochen in einen 3er-Rhythmus bringen. Das macht man, indem man die errechneten Wochenzahlen durch 3 dividiert und schaut, was sich für einen Rest daraus ergibt. Dazu gibt es die genial-simple Formel REST(Woche;3). Das Ergebnis bei REST(Woche;3) bewegt sich im Rhythmus 0, 1, 2, 0, 1, 2 etc. Damit man den Rhythmus 1, 2, 3, 1, 2, 3 etc. erhält (was für die Arbeitsgruppen einfacher und verständlicher ist), haben wir zu diesem Rest noch 1 addiert.
Die drei bedingten Formatierungen lauten also:
=REST(GANZZAHL((A3-1)/7);3)+1=1
=REST(GANZZAHL((A3-1)/7);3)+1=2
=REST(GANZZAHL((A3-1)/7);3)+1=3
Und sie gelten für =$A$3:$A$33;$C$3:$C$33;$E$3:$E$30;$G$3:$G$33
Basierend auf den Formeln für die bedingte Formatierung lassen sich auch die Namen der Personen neben die Spalte schreiben. Zum Beispiel in Spalte B könnte das mittels WENN-Funktion so aussehen:
=WENN(REST(GANZZAHL((A3-1)/7);3)+1=1;"Heiri";WENN(REST(GANZZAHL((A3-1)/7);3)+1=2;"Küde";WENN(REST(GANZZAHL((A3-1)/7);3)+1=3;"Housi";0))). (PCtipp-Forum)


Kommentare

Es sind keine Kommentare vorhanden.