Tipps & Tricks 21.05.2016, 08:00 Uhr

Excel: die Krux mit den variablen und statischen Zellbezügen

Excel-Einsteiger bekunden Probleme damit, ihrem Rechenknecht eines beizubringen: Wann soll Excel einen Zellbezug beim Kopieren anpassen – und wann nicht?
Das automatische Ausfüllen und Anpassen von Formeln in Excel ist ein grosser Segen und nimmt einem immens viel Tipparbeit ab. Damit das klappt, muss man aber den Trick mit dem Dollarzeichen kennen. 
Beim Kopieren einer Formel von der obersten Zelle in die darunter liegenden passt Excel die darin enthaltenen Spalten- und Zeilenbezüge automatisch an. Sie können aber durch Voranstellen eines $-Zeichens festlegen, welche Elemente in der Formel eben gerade nicht angepasst werden sollen. Das zeigen wir am besten an zwei Beispielen.
Beispiel 1 – Formel wird beim Kopieren angepasst:
Angenommen, Sie haben eine Tabelle mit zwei Spalten, die beispielsweise Kalenderdaten enthalten. In Spalte E wollen Sie mit einer einfachen WENN-Formel ein X erscheinen lassen, wenn das erste Datum kleiner als das zweite ist. Nichts leichter als das: Sie schreiben in E2 die Formel =WENN(B2<C2;"X";"") und kopieren diese per AutoAusfüllen in die darunter liegenden Zellen. Vergleichen Sie danach die Formeln in den automatisch ausgefüllten Zellen. Sie werden feststellen, dass Excel mitgedacht und die Formel in jeder Zelle automatisch angepasst hat: In Zelle E3 lautet die Formel daher auch «=WENN(B3<C3;"X";"")», in E4 ist es «=WENN(B4<C4;"X";"")» und so weiter.
Das ist hier auch erwünscht, weil die Zellen, auf die sich die Formeln beziehen müssen, in denselben Zeilen wie die Formel selbst stehen. Der Bezug muss hier also «mitwandern».
Beispiel 2 – Excel soll Teile der Formel beim Kopieren nicht anpassen
Nun gibt es aber Formeln, die sich nicht komplett auf Werte in derselben Zeile beziehen, sondern auf Werte, die anderswo in der Tabelle stehen. Angenommen, Sie möchten das Datum in Spalte B nicht mit einem in Spalte C vergleichen, sondern jedes dieser Daten mit jenem Datum, das Sie in E1 eingetippt haben. Das würde mit der Formel «=WENN(B2>E1;"X";"")» in Zelle D2 noch klappen. Aber wenn Sie diese Formel herunterziehen bzw. autoausfüllen, dann macht Excel in der Zelle D3 diesen Unsinn daraus: «=WENN(B3>E2;"X";"")». Beim Herunterkopieren merkt Excel nicht, dass es den Bezug zu E1 als fixen Bezug erhalten müsste. Es darf diesen Teil der Formel also nicht anpassen.
Hier kommen die Dollarzeichen ins Spiel. Fügen Sie in der Formel vor der Spalten- und Zeilenangabe des fixen bzw. statischen Bezuges jeweils ein Dollarzeichen ein. Die Formel in D2 muss also korrekterweise so lauten: =WENN(B2>$E$1;"X";"")
Excel passt den mit $-Zeichen versehenen Zellbezug beim AutoAusfüllen nicht automatisch an
Kopieren Sie diese in die darunterliegenden Zellen und vergleichen Sie die Formeln erneut. Sie stellen fest, dass Excel den Zellbezug ohne die Dollarzeichen wie bis anhin automatisch angepasst hat (z.B. B2 wird in Zeile 12 zu B12); aber es lässt den Bezug mit den Dollarzeichen brav in Ruhe: $E$1 bleibt $E$1 und wird beim AutoAusfüllen nicht tangiert.


Kommentare

Es sind keine Kommentare vorhanden.