Tipps & Tricks 24.01.2022, 00:35 Uhr

Excel: Summe aller Einträge pro Monat

Sie haben übers Jahr eine Liste mit Beträgen und Kalenderdaten erstellt. Nun brauchen Sie in Excel oder LibreOffice eine Formel, mit der Sie alle Beträge für jeden Monat zusammenzählen können.
Lösung: Die Lösung für Ihr Problem ist die Funktion SUMMEWENN(). Diese sucht in einer Spalte nach bestimmten Werten und zählt dann die Werte in einer anderen Spalte, aber in der gleichen Reihe, zusammen. Für Ihr Problem müssen Sie aber zusätzlich mit der Funktion MONAT() den Monat aus dem Datum holen. Schreiben Sie ihn in eine zusätzliche Spalte, die Sie später verstecken können.
Als Erstes fügen Sie nun also neben der Spalte mit dem Datum eine neue Spalte ein. In der obersten Zeile fügen Sie folgende Formel ein: =MONAT(A2). A2 muss durch die oberste Datumszelle in Ihrem Arbeitsblatt ersetzt werden. Dann vervollständigen Sie die ganze Spalte nach unten. Nun sollte die ganze Spalte jeweils die Nummer des Monats des entsprechenden Datums enthalten.
Jetzt gehts zur «grossen» Formel. Unsere Beispieltabelle hat 600 Zeilen. Dort, wo Sie die Summen für den Monat Januar haben wollen, fügen Sie folgende Formel ein: =SUMMEWENN($B$2:$B$600;1;$C$2:$C$600). Als ersten Parameter (hier B2:B600) übergeben wir die Werte, nach denen Excel suchen soll, also unsere Monate, die bei uns in der Spalte B stehen. Als zweiten Parameter geben wir an, wonach Excel suchen soll. Der Januar ist Monat 1, Februar Monat 2 und so weiter. Klingt logisch, oder? Als Drittes müssen wir Excel noch sagen, welche Werte es zusammenzählen soll. Im Beispiel ist es der Bereich von C2 bis C600. Die Zahlen im ersten und im dritten Parameter müssen sich natürlich entsprechen, sonst ergibt die Formel keinen Sinn!
Die Formel =MONAT(A2) trägt in einer Hilfsspalte den Monat ein, den wir in der eigentlichen Formel als SUMMEWENN-Kriterium benutzen können
Quelle: PCtipp.ch
Jetzt können Sie diese Formel auch für die anderen Monate übernehmen und entsprechend anpassen. Achten Sie beim Kopieren der Formel darauf, dass sich die referenzierten Spalten und Zeilen nicht ändern. Am besten setzen Sie bei den fixen Bezügen jeweils ein $ ein, damit es «stabil» bleibt. Also zum Beispiel: $B$2:$B$600. Zum Schluss blenden Sie die Spalte mit der Monatsnummer auf Wunsch noch aus: Spalte markieren, ein Rechtsklick drauf und Ausblenden.
Hinweis: Dasselbe funktioniert genau gleich auch in LibreOffice Calc.
(Ursprung 28.1.2005, Update auf aktuelle Excel- und LibreOffice-Version 21.1.2022)



Kommentare

Avatar
Turakos
24.01.2022
Hallo Gaby Weitere Möglichkeit des Umsatzes in einem Monat mit einer Pivot-Tabelle. Freundliche Grüsse Turakos

Avatar
Mano58
25.01.2022
Liebe Gaby Auch hier gibt es eine schönere Lösung. Nur muss in der Spalte E ein Datum für den Monat eingetragen sein. E2 = 1.1.2021, E2 = EDATE(E2,1) und kopieren bis E13 und dementsprechend formatieren. Und jetzt geht das ganze ohne störende und überflüssige Hilfsspalte: F2 = SUMMENPRODUKT( (TEXT(A$2:A$600, "JJJJMM")=TEXT(E2,"JJJJMM"))*C$2:C$600) Und dann F2 runterkopieren bis F13. Herzliche Grüsse Mano