Tipps & Tricks 21.03.2005, 21:30 Uhr

Excel-Berechnung: Arbeitszeit endet erst nach Mitternacht

Wie kann ich eine Differenz von Zeitwerten ausrechnen, wenn der zweite Wert nach Mitternacht liegt? Beispiel: Start 22:00 Uhr, Ende (am Folgetag) um 05:00 Uhr. Die Dauer beträgt 7 Stunden. Anders formuliert: In Zelle A3 möchte ich als Ergebnis die Differenz von Zelle A2 (05:00(Folgetag)) und Zelle A1 (22:00).
Das ist wieder eine dieser etwas kniffligen Angelegenheiten bei der Berechnung von Zeiten in Excel. Die Lösung ist aber gar nicht so schwer. Sie müssen einfach, da Sie über die Datumsgrenze um Mitternacht hinausgehen, die 24 Stunden des Vortages dem neuen Tag hinzufügen.
Die Formel in der Zelle A3 sieht dazu folgendermassen aus:
="24:00"+(A2-A1)
Das Ergebnis ist dann wie gewünscht 7:00.
Falls Sie mit derselben Formel auch Zeiten berechnen wollen, die nicht über Mitternacht hinausgehen, also beispielsweise in Zelle A1 den Wert 8:00 und in Zelle A2 den Wert 17:00 stehen haben und ebenfalls die Differenz ausrechnen wollen, würde diese Formel allerdings nicht ausreichen. In diesem Falle müssen Sie noch eine WENN-Abfrage einbauen:
=WENN(A1<=A2;A2-A1;"24:00"+(A2-A1))
So wird also erst einmal geprüft, ob der Wert, der in A1 steht, eventuell kleiner ist als der Wert in A2. Ist dies der Fall, wird ganz einfach A1 von A2 subtrahiert. Wenn die Prüfung aber negativ ausfällt, der Wert in A1 also grösser ist als in A2 wie in dem von Ihnen beschriebenen Fall, werden 24 Stunden hinzugerechnet. So stimmt die Berechnung dann für alle eintretenden Fälle.
In Wirklichkeit rechnet Excel jedoch nicht mit 24:00 bzw. 24 Stunden, sondern mit der Zahl 1. Hier der mathematische Hintergrund in Kürze: Für Excel sind Zeitangaben von 00:00 - 24:00 Uhr Zahlen zwischen 0 und 1. 00:00 Uhr ist also 0 (Null), und 24:00 Uhr ist 1 (Eins). 22:00 Uhr ist demnach rund 0.92, und 05:00 Uhr ist ca. 0.21. Wenn Sie jetzt die Zeitdifferenz zwischen 05:00 Uhr und 22:00 Uhr berechnen, dann rechnet Excel im Hintergrund 0.92-0.21=0.71, und 0.71 macht 17 Stunden. Der umgekehrte Fall (22:00 Uhr bis 05:00) würde eine negative Zahl ergeben (-0.71), und das kann Excel nicht in Stunden ausdrücken, da eine negative Zahl nicht zwischen 0 und 1 liegt. Und selbst wenn Excel schlau genug wäre und einfach den Wert der Zahl ohne Vorzeichen nehmen würde, wäre das Ergebnis noch immer falsch: Denn ohne negatives Vorzeichen ist 0.71 gleich 17 Stunden. Wir möchten aber als Ergebnis 7 Stunden erhalten: 24-17=7, oder 1-0.71=0.29 oder noch besser -0.71+1=0.29. Und weil in Stunden ausgedrückt 1 den 24 Stunden entspricht, addieren Sie zum negativen Ergebnis 24:00 hinzu. Sie können natürlich auch mit der 1 rechnen, so dass die Beispielformel dann lauten würde:
=WENN(A1<=A2;A2-A1;1+(A2-A1))
Ob Sie mit 1 rechnen oder des besseren Verständnisses wegen "24:00" hinschreiben, spielt keine Rolle.


Kommentare

Es sind keine Kommentare vorhanden.