Tipps & Tricks 27.06.2013, 06:00 Uhr

Excel: Ort-/Zeitkonflikt ermitteln

Problem: Hier müssen Personen je nach Einsatzplan in Zürich oder Bern arbeiten. Zum Beispiel Hans an einem Tag von 8-12 in Bern, am nächsten Tag von 13-16 in Zürich, manchmal auch von 8-12 und 13-16 in Zürich. Die Orte und Zeiten wechseln. Nun kann es passieren, dass z.B. Hans im Arbeitsplan am gleichen Tag von 8-12 in Bern und von 13-16 in Zürich vorgemerkt ist. Das möchte ich verhindern; sie sollen nicht am gleichen Tag zwei verschiedene Einsatzorte haben. Gibt es eine Formel zum Anzeigen solcher Konflikte?
Lösung: Die Liste ist aufsteigend sortiert nach IDPerson/Datum/Zeitspanne. 
Verwenden Sie eine bedingte Formatierung. Hierfür haben wir eine Hilfsspalte E «String» eingefügt mit dem Inhalt aus den Spalten «IDPerson»&«Datum» (=A2&A3). Diese Hilfsspalte dient dem Ermitteln der doppelten Datensätze bezogen auf diese beiden relevanten Spalten.
Markieren Sie nun den gesamten Zellenbereich und gehen zu Start/Formatvorlagen/Bedingte Formatierung/Neue Regel/Formel zur Ermittlung der zu formatierenden Zellen verwenden. Geben Sie diese Formel ein:
=ZÄHLENWENN($E$2:$E2;$E2)>2 
Verwenden Sie als Kennzeichnung z.B. ein Orange. Lassen Sie die Zellen danach gleich markiert und gehen erneut zu Start/Formatvorlagen/Bedingte Formatierung/Neue Regel/Formel zur Ermittlung der zu formatierenden Zellen verwenden. Jetzt tippen Sie die folgende Formel ein:
=WENN(ZÄHLENWENN(E$2:$E2;$E2)>1;NICHT(IDENTISCH($B2;$B1));"")
Legen Sie auch hier dasselbe Orange fest. 
Die zwei Formeln zur bedingten Formatierung
Die Regel formatiert die erste(n) Folge-Zeile(n), die im Konflikt zur ersten Zeile steht, mit gleicher «IDPerson» und mit gleichem «Datum», aber ungleichem «Ort» (am gleichen Tag), siehe Screenshot.
Für eine allfällige Realisierung könnte die Angabe der Zeitspanne eventuell zu Problemen führen. (PCtipp-Forum)


Kommentare

Es sind keine Kommentare vorhanden.