Tipps & Tricks 25.05.2006, 15:00 Uhr

Excel: Zelle leer oder Text vorhanden?

Ich habe bisher folgendes gemacht: Wenn in der Zelle B2 eine Zahl grösser 0 steht, wird in der Zelle A2 eine 1 eingetragen; wenn nichts in der Zelle B2 steht, wird in der Zelle A2 eine 0 eingetragen. Ich möchte dann zum Schluss feststellen, wie viele Zellen einen Eintrag enthalten. Das funktioniert bis jetzt mit Zahlen gut. Mein Problem ist, dass ich in den Zellen B1 bis B50 keine Zahlen habe, sondern Text, und ich möchte wissen in wieviel Zeilen ein Text steht. Diesen Wert möchte in Zelle A51 ausgeben.
Ob in einer Zelle Text oder eine Zahl steht, ist eigentlich egal, wenn Sie nur wissen wollen, ob die Zelle gefüllt ist. Die Formel ist immer dieselbe, nämlich
=WENN(B2>0;1;0)
In Worten ausgedrückt: Wenn in Zelle B2 etwas steht bzw. der Wert grösser als 0 ist, gib eine 1 aus, wenn nichts in der Zelle steht bzw. der Wert kleiner gleich 0 ist, gib eine 0 aus.
Das funktioniert auch mit Text, wie Sie hier sehen können:
Wenn Sie jedoch lediglich wissen wollen, wie viele Zellen einen Text enthalten, können Sie das auch ohne diese Abfrage lösen, denn dafür gibt es in Excel die Funktion ANZAHL2().
Geben Sie also in der Ergebniszelle einfach nur ein:
=ANZAHL2(B2:B50)
und Sie erhalten die Anzahl der Zellen, die einen Text enthalten.

Kommentare

Es sind keine Kommentare vorhanden.