Tipps & Tricks 05.04.2004, 13:30 Uhr

Excel: Doppelte Einträge nur einmal zählen

Ich möchte in einer Spalte mit Dossiernummern (mit Doppelnennungen) die Anzahl Dossiers ohne Doppelnennungen ermitteln. Jedes vorhandene Dossier soll nur einmal gezählt werden, auch wenn es mehrmals vorkommt.
Für unser Beispiel nehmen wir einmal an, dass Sie die Dossiernummern in Spalte A aufgelistet haben, dann geben Sie folgende Formel in Zelle B1 ein:
=WENN(VERGLEICH(A1;A:A;0)=ZEILE();"Einfach";"Doppelt")
Wenn Sie diese Formel für die gesamte Spalte mit AutoAusfüllen herunterziehen, erhalten Sie dieses Ergebnis:
Nun haben Sie eine Markierung, die Sie zählen können. Dafür eignet sich die Funktion ZÄHLENWENN.
In Zelle C1 geben Sie ein:
=ZÄHLENWENN(B:B;"Einfach")
Damit haben Sie alle Dossiers nur einmal gezählt, auch wenn sie doppelt vorkommen.

Kommentare

Es sind keine Kommentare vorhanden.