Tipps & Tricks 07.01.2004, 12:00 Uhr

Excel: Datumswerte in WENN-Funktion

In einer Zelle stehen Eintrittsdaten von Mitarbeitern. Ist der Mitarbeiter vor dem 01.01. des aktuellen Jahres in den Betrieb eingetreten, soll das Datum 01.01. des aktuellen Jahres in eine andere Zelle eingetragen werden. Ist das Eintrittsdatum im aktuellen Jahr, z.B. 25.03., soll dieses Datum eingetragen werden.
Das Problem können Sie mit der WENN-Funktion lösen: Wenn das Eintrittsdatum kleiner ist als der 01.01. des aktuellen Jahres, dann schreibe 01.01. des aktuellen Jahres in die Zelle, ansonsten das Eintrittsdatum. Und damit die Jahreszahl variabel bleibt, verwenden Sie die Funktion JAHR(HEUTE()), sie extrahiert das Jahr aus dem heutigen Datum. Monat und Tag sind feste Werte. Die fertige Funktion sieht dann so aus:
Zum Kopieren hier die Formel noch einmal in Textform:
=WENN(A1<DATUM(JAHR(HEUTE());1;1);DATUM(JAHR(HEUTE());1;1);A1)

Kommentare

Es sind keine Kommentare vorhanden.